Notifications
Clear all

Nvidia boot.  

 
David Cassidy
(@sages)
Member

Hello, iv installed nvidia and have the driver working well, but there is a small thing that happens on boot.

To boot i have to go into recovery mode and from there just resume with boot and it fires up. I just wanted to post somthing about it as, some people will boot normally and the nvidia driver wont load. sorry im not very tech. XD

 

driver 460.67

Quote
Topic starter Posted : 07/04/2021 1:19 pm
Topic Tags
Thomas Castleman
(@batcastle)
Member
Posted by: @sages

Hello, iv installed nvidia and have the driver working well, but there is a small thing that happens on boot.

To boot i have to go into recovery mode and from there just resume with boot and it fires up. I just wanted to post somthing about it as, some people will boot normally and the nvidia driver wont load. sorry im not very tech. XD

 

driver 460.67

Sorry for the late response!

 

When you boot in that way, the proprietary Nvidia driver is not loading. Instead, the open-source Nouveau driver is loading. Currently when you boot normally your kernel is trying to use both drivers. If you do not allow installation of Restricted Extras during OS installation, then you have a couple hoops to jump through to get the Nvidia drivers running the first time you install them.

 

  1. In the Additional Drivers app, install whichever driver you prefer
  2. Open a terminal window, and run the following command. Make sure you spell it right, otherwise it will not work correctly: echo -e "blacklist nouveau\noptions nouveau modeset=0" | sudo tee /etc/modprobe.d/blacklist-nvidia-nouveau.conf
  3. Next, run the following command if you installed using UEFI: sudo /etc/kernel/postinst.d/zz-update-systemd-boot

Now you should be good to shut down, boot up normally, and get running!

If your default boot option is the Recovery option, try this (if you are using UEFI):

  1. Once you get to the boot menu, use the arrow keys to select which option you want to be default.
  2. Once your desired default is selected, hit "D", you should get a message at the bottom of the screen indicating the default has been set.
  3. Just hit Enter and it should boot from there!
ReplyQuote
Posted : 12/05/2021 10:20 pm