Struggling to insta...
 
Notifications
Clear all

Struggling to install winehq-staging

 
beta seeker
(@betaseeker)
Member

Hi,

I'm looking to install winehq-staging for use with Lutris but I am caught in a dependency hell and I'm struggling to find a working solution out in the internet.

Here is the situation:

sudo apt install --install-recommends winehq-staging wine-staging wine-staging-i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 wine-staging-i386:i386 : Depends: libpulse0:i386 (>= 0.99.1) but it is not going to be installed
                          Depends: libvkd3d1:i386 (>= 1.2~focal-1) but it is not going to be installed
                          Depends: libasound2-plugins:i386 but it is not going to be installed
                          Recommends: libcups2:i386 but it is not going to be installed
                          Recommends: libdbus-1-3:i386 but it is not going to be installed
                          Recommends: libgtk-3-0:i386 but it is not going to be installed
                          Recommends: libsane:i386 but it is not going to be installed or
                                      libsane1:i386
                          Recommends: libsdl2-2.0-0:i386 but it is not going to be installed
                          Recommends: libva-drm2:i386 but it is not going to be installed or
                                      libva-drm1:i386 but it is not installable
                          Recommends: libva-x11-2:i386 but it is not going to be installed or
                                      libva-x11-1:i386 but it is not installable
                          Recommends: libva2:i386 but it is not going to be installed or
                                      libva1:i386 but it is not installable
E: Unable to correct problems, you have held broken packages.

And here is how my apt mirrors are:

# See  http://help.ubuntu.com/community/UpgradeNotes  for how to upgrade to
# newer versions of the distribution.
deb  http://us.archive.ubuntu.com/ubuntu/  focal main restricted
# deb-src  http://us.archive.ubuntu.com/ubuntu/  focal main restricted multiverse universe

## Major bug fix updates produced after the final release of the
## distribution.
deb  http://us.archive.ubuntu.com/ubuntu/  focal-updates main restricted
# deb-src  http://us.archive.ubuntu.com/ubuntu/  focal-updates main restricted multiverse universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb  http://us.archive.ubuntu.com/ubuntu/  focal universe
deb  http://us.archive.ubuntu.com/ubuntu/  focal-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb  http://us.archive.ubuntu.com/ubuntu/  focal multiverse
deb  http://us.archive.ubuntu.com/ubuntu/  focal-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb  http://us.archive.ubuntu.com/ubuntu/  focal-backports main restricted universe multiverse
# deb-src  http://us.archive.ubuntu.com/ubuntu/  focal-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb  http://archive.canonical.com/ubuntu  focal partner
# deb-src  http://archive.canonical.com/ubuntu  focal partner

deb  http://security.ubuntu.com/ubuntu  focal-security main restricted
# deb-src  http://security.ubuntu.com/ubuntu  focal-security main restricted multiverse universe
deb  http://security.ubuntu.com/ubuntu  focal-security universe
deb  http://security.ubuntu.com/ubuntu  focal-security multiverse

# Extra Repos added for Drauger OS
deb  https://apt.draugeros.org  zombi main
# deb  https://apt.draugeros.org  zombi main
# deb  https://apt.draugeros.org  zombi main
# UNCOMMENT ABOVE LINE WHEN NO MORE CERT EXPIRED ERRORS
# Development Repos for Drauger OS
# ONLY ENABLE IF YOU ARE WILLING TO DEAL WITH BUGS
# deb  https://apt.draugeros.org  zombi-dev main
deb  https://dl.winehq.org/wine-builds/ubuntu/  focal main
# deb-src  https://dl.winehq.org/wine-builds/ubuntu/  focal main

Would be glad for any help into the right direction!

Quote
Topic starter Posted : 16/11/2021 12:33 am
beta seeker
(@betaseeker)
Member

Referred to this:

https://forum.winehq.org/viewtopic.php?t=33955

And this is the result when I try to install libasound2-plugins

sudo apt install libasound2-plugins:i386 libpulse0:i386 libdbus-1-3:i386 libsystemd0:i386 liblz4-1:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 at-spi2-core : Depends: libdbus-1-3 (>= 1.9.14) but it is not going to be installed
 dbus : Depends: libdbus-1-3 (= 1.12.16-2ubuntu2.1) but it is not going to be installed
 dconf-gsettings-backend : Depends: dconf-service (>= 0.36.0-1)
                           Depends: dconf-service (< 0.36.0-1.1~)
 gnome-keyring : Depends: gcr (>= 3.4) but it is not going to be installed
                 Depends: default-dbus-session-bus or
                          dbus-session-bus
                 Depends: pinentry-gnome3 but it is not going to be installed
 gnome-session-bin : Depends: dbus-x11
                     Depends: upower (>= 0.9.0)
                     Recommends: gnome-startup-applications but it is not going to be installed
 gnome-shell : Depends: gir1.2-geoclue-2.0 but it is not going to be installed
               Depends: gir1.2-nma-1.0 but it is not going to be installed
               Depends: gnome-settings-daemon (>= 3.16.0) but it is not going to be installed
               Recommends: gdm3 (>= 3.10.0.1-3~) but it is not going to be installed
               Recommends: gkbd-capplet but it is not going to be installed
               Recommends: gnome-control-center (>= 1:3.25.2) but it is not going to be installed
               Recommends: ubuntu-session but it is not going to be installed or
                           gnome-session but it is not going to be installed
 gnome-user-docs : Depends: ubuntu-docs (>= 18.04.1~) but it is not going to be installed
                   Depends: yelp (>= 3) but it is not going to be installed
 ibus : Depends: ibus-data (= 1.5.22-2ubuntu2.1) but it is not going to be installed
        Recommends: ibus-gtk but it is not going to be installed
        Recommends: ibus-gtk3 but it is not going to be installed
 libarchive13 : Depends: liblz4-1 (>= 0.0~r130) but it is not going to be installed
 libatk-bridge2.0-0 : Depends: libdbus-1-3 (>= 1.9.14) but it is not going to be installed
 libatspi2.0-0 : Depends: libdbus-1-3 (>= 1.9.14) but it is not going to be installed
 libgoa-1.0-0b : Depends: libgoa-1.0-common (>= 3.36.1-0ubuntu1) but it is not going to be installed
 libgtk-3-0 : Depends: libcups2 (>= 2.3~b6) but it is not going to be installed
              Recommends: libgtk-3-bin
 libpam-systemd : Depends: systemd (= 245.4-4ubuntu3.13)
                  Depends: systemd-sysv
 libpulse0 : Depends: libdbus-1-3 (>= 1.9.14) but it is not going to be installed
 libqt5widgets5 : Depends: libqt5gui5 (>= 5.12.5) but it is not going to be installed or
                           libqt5gui5-gles (>= 5.12.5) but it is not going to be installed
 libqt5x11extras5 : Depends: libqt5gui5 (>= 5.12.8+dfsg~) but it is not going to be installed or
                             libqt5gui5-gles (>= 5.12.8+dfsg~) but it is not going to be installed
 libsystemd0 : PreDepends: liblz4-1 (>= 0.0~r122) but it is not going to be installed
 libwebkit2gtk-4.0-37 : Depends: libjavascriptcoregtk-4.0-18 (= 2.34.1-0ubuntu0.20.04.1) but it is not going to be installed
                        Recommends: gstreamer1.0-pulseaudio but it is not going to be installed or
                                    gstreamer1.0-alsa but it is not going to be installed
 procps : Depends: libprocps8 (>= 2:3.3.16-1) but it is not going to be installed
 xserver-xorg : Depends: xserver-xorg-core (>= 2:1.17.2-2) but it is not going to be installed
                Depends: xserver-xorg-input-all but it is not going to be installed or
                         xorg-driver-input
                Depends: python3-apport but it is not going to be installed
                Recommends: xserver-xorg-video-all but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

I don't even want to begin wrecking my Drauger Install when there's no backup system in-hand just yet lol

ReplyQuote
Topic starter Posted : 16/11/2021 12:39 am
Thomas Castleman
(@batcastle)
Member

So some versions of Wine from the package manager are having issues installing (like what you are seeing). It IS NOT fixed by adding the WineHQ repository. In order to get the Wine version you are wanting, I typically suggest one of 2 things:

A) run whatever it is you are trying to run through PlayOnLinux if you need a specific Wine version. Otherwise, try Steam's Proton (you can add the app as a non-Steam game) or Lutris.

 

B) hold off on installing that app/game until December 4th. That's the day the next version of Drauger OS comes out. You can upgrade your system with a script that will be available in the repos and start beta testing that version of Drauger OS, while also fixing the issues you are having.

ReplyQuote
Posted : 17/11/2021 8:49 pm
beta seeker
(@betaseeker)
Member

@batcastle Hi Thomas,

First of all, thank you very much for all the hard work you're doing for DraugerOS! I'll be supporting the project financially from time to time and it's the least that I could do.

Apparently, I've recently uninstalled PlayonLinux with the intention of installing a much more recent version only for me to fail lol. Cause it actually needs wine32 to get installed too :/

Thanks for letting me know about option B, that looks to be the most sound option that I have here.

I have some questions about it though:

1. The upgrade script isn't necessarily a full OS reinstall right? I've performed major version upgrades with Linux in the past that didn't involve a reinstall and I'd like to know if the sense is pretty much the same.

2. Asides from reporting bugs by making an Issue in the github repository as stated in https://draugeros.org/go/contribute/ , are there more ways I can do to contribute to Beta testing the next Drauger OS version?

3. I'm using an AMD Ryzen system, will that not get in the way of sound testing?

 

For now, I have a workaround going which is the use of a wine32 appimage which serves as both my current wine and wine-server.

The things that suck about it though are:

1. I can't seem to make it work with Japanese fonts and locale

2. It's only wine32 and not both wine32 + wine64 which is meh hahahaha

ReplyQuote
Topic starter Posted : 19/11/2021 10:27 pm
Thomas Castleman
(@batcastle)
Member

@betaseeker I'll try to answer your questions as best I can.

 

1. The upgrade script is not a full reinstall. It does require the use of a terminal, but is not difficult to use.

 

2. If you know Python, it can be helpful in finding fixes or pinpointing where a bug is. If not, contributing financialy or reporting bugs are the quickest and easiest ways to contribute. Once you get more experience with the OS, you can also contribute by helping others with bugs.

 

3. AMD vs Intel shouldn't make a difference in sound testing. I use Drauger OS on both AMD and Intel systems with both Pulse and Pipewire. Both have worked well with minimal sound-specific issues.

ReplyQuote
Posted : 19/11/2021 10:52 pm
beta seeker
(@betaseeker)
Member

@batcastle Thank you very much for the responses.

1. Sounds great, looking forward to it!

2. I don't have much experience with Python but I have a few years of experience in coding and I tend to excel more on pinpointing the code that causes the bug or portion of code that eventually leads to the bug. I'll try to do just that whenever I find bugs on the beta release. I hope to be able to contribute financially too by Christmas.

About helping others with bugs, I'm actually concerned that not much people are here in the forums lol. Do you happen to know where a good chunk of Drauger's community is? I checked reddit but even there is just about 42 people.

3. Awesome! Ayt, rock and roll with beta testing soon hahaha

Pardon me for replying 5 days late, I'm actually juggling between work, studies, and extra activities at the moment.

ReplyQuote
Topic starter Posted : 24/11/2021 11:16 pm
Thomas Castleman
(@batcastle)
Member

@betaseeker The late reply is fine. I used to have issues replying to stuff on here so it's not a big deal.

 

Most of our community is on Discord, but a good chunk is on Telegram too. Links to both those can be found in the footer of this website or in the Welcome Screen. It's not TOO active but more people is always a good thing.

ReplyQuote
Posted : 24/11/2021 11:35 pm
beta seeker
(@betaseeker)
Member

Thanks! I'll go ahead and join the discord server

ReplyQuote
Topic starter Posted : 26/11/2021 1:39 am